Insights Dashboard Unavailable

Incident Report for Monument Software

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 15:24 UTC

Investigating

We are currently investigating the issue causing Insights to be unavailable.
Posted Oct 24, 2025 - 15:03 UTC
This incident affected: Facility Management System (Insights).